Imaging Spectrum Blog

2×6 Photobooth Strips with HiTi P510S Photo Printer

HiTi P510S with 2x6 Photo Strips

Update: This procedure will also work for the HiTi P510L

Are you having trouble printing 2×6 photobooth strips with your HiTi P510S Photo Printer? We have noticed that some of the HiTi P510S Printers ship with an older driver CD that does not include the option for the 2×6 strip. Fortunately, there is an easy fix – cruise on over to the HiTi website and download the correct driver for your operating system and install it on your computer. (Please note this quirk: with Windows 7, make sure the printer is not plugged in and powered on while installing the printer driver.) After you install the driver, you will see there is an option for “6×4 Split (6×2 2 prints)” – see screen shot below. Select that paper size in order to print two 2×6 photo strips. If you are using a photobooth software, such as Breeze, the print size needs to be selected in the print driver as well as in the software.


Of course, if you have any questions, feel free to shoot me an email.



  1. Bill Vahrenkamp

    October 17, 2011 - 1:01 pm

    BTW, this setup works with the P510L also. The printer was not out when this post was originally written. Bill

  2. Bill Vahrenkamp

    December 30, 2011 - 11:03 am

    These same directions also work with the HiTi P510L.

  3. Keith Cain

    May 12, 2015 - 12:43 pm

    I have the Hiti 520L and I am having a problem getting the 2×6 strips, I have the Darkroom booth software but the 6×2 2 option will not show for me in the software, but I did see that option for my printer somewhere else on my computer and chose it but I still am not getting the cut

  4. Bill Vahrenkamp

    May 13, 2015 - 3:03 pm

    Make sure the paper size is set to the setting above and you can test print correctly. In Booth under the Settings Tab, make sure it is set to Print, 2×6 2 copies. If not working, remove printer under Printer options in Global Settings and then add back in.

  5. Girrard Del Pilar

    July 31, 2015 - 11:37 pm

    Same as Keith. Followed your instructions re: driver, removing printer, etc. Double checked all settings to choose 2×6 2 copies on printer and Darkroom settings. Still encountering the same issue!

  6. Jeremy Doan

    September 1, 2015 - 10:00 pm

    I have the exact same issue in Darkroom. Is there a solution?
    Thank you,

  7. Bill

    September 1, 2015 - 10:48 pm

    My reply back from May 13 has worked 100% of the time. If you are having issues call ISI for a tech ticket and we can log on and set it.

Leave a Reply

Your email address will not be published. Required fields are marked *